HDF5 Handler

This is the HDF5 file module for Hyrax, developed by THG, Inc. in cooperation with OPeNDAP.

Our software distributions are signed using a public/private key pair. See Public Key for more information.


HDF5 handler 1.4.3 / Hyrax 1.6.2 (15 September 2010)

Note: This version is part of the Hyrax 1.6.2 Release and requires this version of the server to function properly.

This version is a compatibility upgrade for Hyrax 1.6.2 and also includes numerous bug fixes, including:

  • A bug in the Grid lat/lon calculation logic is fixed.
  • Added XDim and YDim to the name conversion map.
  • Rare memory overwrite bug fixed.
  • Please see the ChangeLog for the full listing.

    Source code

    Version 1.4.3
    tar.gz, gpg signature. Required: libdap 3.11.0, bes 3.9.0

    Binaries

    Linux Linux (x86_64)
    CentOS 5.2, RPMs (gcc 4.1)
    Linux Linux (i386)
    CentOS 5.2, RPMs (gcc 4.1)

    Contributed builds

    Version 1.4.3
    Contributed: Sharing your binary builds for those operating systems not available here.

    HDF5 handler 1.4.1 (13 May 2010)

    This release contains performance improvements when using HDF5 1.8

    Source code

    Version 1.4.1
    tar.gz, gpg signature. Required: libdap 3.10.2, bes 3.8.3

    Binaries

    Linux Linux (x86_64)
    CentOS 5.2, RPMs (gcc 4.1)
    Linux Linux (i386)
    CentOS 5.2, RPMs (gcc 4.1)

    Contributed builds

    Version 1.4.1
    Contributed: Sharing your binary builds for those operating systems not available here.

    HDF5 handler 1.4.0(9 February 2010)

    This release can handle HDF-EOS5 Swath products with more robustness than the previous version so more visualization clients can display them.

    Other fixes:

  • Source release and cent0S 5.2 i386 and x86_64 binary release of the HDF5 handler.
  • The coordinates attribute for 2D-swath case and the missing dimension names in the old (2007) OMUVB product were corrected.
  • Problems with the binary build have been fixed.
  • Known problems:

  • This release will return an error for an HDF-EOS5 file that has multiple Swaths.
  • Source code

    Version 1.4.0
    tar.gz, gpg signature. Required: libdap 3.10.0, bes 3.8.0

    Binaries

    Contributed builds

    Version 1.4.0
    Contributed: Sharing your binary builds for those operating systems not available here.

    HDF5 handler 1.3.4 (6 October 2009)

    Special source-only release of the HDF5 handler including new features implemented by The HDF Group.

    This version of the HDF5 handler presents information stored in HDF-EOS and HDF-EOS2 files in a far more friendly way than the previous handlers. The resulting data sets are much easier for client to process and users to understand and use.

    Source code

    Version 1.3.4
    tar.gz, gpg signature. Required: libdap 3.9.3, bes 3.7.2

    Contributed builds

    Version 1.3.4
    Contributed: Sharing your binary builds for those operating systems not available here.

    HDF5 handler 1.3.3 (15 June 2009)

    This release fixes build problems with gcc 4.3

    Binaries

    Linux Linux (x86_64)
    CentOS 5.2, RPMs (gcc 4.1, requires hdf5 and hdf5-devel rpm packages version 1.8.0 or higher, which can be found at rpmfind)
    Linux Linux (i386)
    CentOS 5.2, RPMs (gcc 4.1)
    OS/X Apple OS/X (10.4)
    Intel DMG (gpg signature), PPC DMG (gpg signature)

    Source code

    Version 1.3.3
    tar.gz, gpg signature. Required: libdap 3.9.3, bes 3.7.2

    Contributed builds

    Version 1.3.3
    Contributed: Sharing your binary builds for those operating systems not available here.

    HDF5 handler 1.3.2 (13 April 2009)

    Fixes and updates for the new BES features.

    Binaries

    Linux Linux (x86_64)
    CentOS 5.2, RPMs (gcc 4.1)
    Linux Linux (i386)
    CentOS 5.2, RPMs (gcc 4.1)
    OS/X Apple OS/X (10.4)
    Intel DMG (gpg signature), PPC DMG (gpg signature)

    Source code

    Version 1.3.2
    tar.gz, gpg signature. Required: libdap 3.9.2, bes 3.7.2

    Contributed builds

    Version 1.3.2
    Contributed: Sharing your binary builds for those operating systems not available here.

    HDF5 handler 1.2.3 (23 July 2008)

    This release fixes a problem with the CF conventions support when also using the short-names option.

    Binaries

    Linux Linux (x86_64)
    Fedora Core 8, RPMs (gcc 4.1)
    Linux Linux (i386)
    Fedora Core 8, RPMs (gcc 4.1)
    OS/X Apple OS/X (10.4)

    Source code

    Version 1.2.3
    tar.gz, gpg signature. Required: libdap 3.8.2, bes 3.6.2 (for Hyrax –this is required to build the BES modules).

    Contributed builds

    Version 1.2.3
    Contributed: Sharing your binary builds for those operating systems not available here.

    HDF5 handler 1.2.2 (27 June 2008)

    This binary release works with the new API changes in libdap 3.8.2 and bes 3.6.2. The handler source code is unchanged.

    Binaries

    Linux Linux (x86_64)
    Fedora Core 8, RPMs (gcc 4.1)
    Linux Linux (i386)
    Fedora Core 8, RPMs (gcc 4.1)
    OS/X Apple OS/X (10.4)

    Source code

    Version 1.2.2
    tar.gz, gpg signature. Required: libdap 3.8.2, bes 3.6.2 (for Hyrax –this is required to build the BES modules).

    Contributed builds

    Version 1.2.2
    Contributed: Sharing your binary builds for those operating systems not available here.

    HDF5 handler 1.2.2 (18 March 2008)

    Binaries

    Linux Linux (x86_64)
    Fedora Core 8, RPMs (gcc 4.1)
    Linux Linux (i386)
    Fedora Core 6, RPMs (gcc 4.1)
    OS/X Apple OS/X (10.4)

    Source code

    Version 1.2.2
    tar.gz, gpg signature. Required: libdap 3.8.0, bes 3.6.0 (for Hyrax –this is required to build the BES modules).

    Contributed builds

    Version 1.2.2
    Contributed: Sharing your binary builds for those operating systems not available here.

    HDF5 handler 1.2.0 (18 January 2008)

    Binaries

    This is a source-only release and is classed as 'beta' level until we can complete a security review of the software. Our current policy is to only provide beta releases of software until we have completed a security review.

    If you require this review before you can run the software, please let us know!

    7 Feb 2008: This handler works with the CGI-based server and with the lastest (source/subversion) version of Hyrax.

    Source code

    Version 1.2.0
    tar.gz, gpg signature. Required: libdap 3.7.10, bes 3.5.3 (for Hyrax –this is required to build the BES modules).

    Contributed builds

    Version 1.2.0
    Contributed: Sharing your binary builds for those operating systems not available here.