Back to top

DAP++ SDK 3.5.2 (15 Aug 2005)

Submitted by jimg on Mon, 08/15/2005 - 12:49

This update to 3.5.1 includes fixes to problems reported with the 3.5.1 and 3.5.0 beta releases and a vastly reworked build. The build now uses autoconf/make and libtool and produces both a static and shared library. Included with the source is a RPM spec file which can be used to produce both RPM source and binary distributions. Both the Makefile builds and the rpm builds have had extensive work to bring them inline with the Fedora project's requirements, thanks to Patrice Dumas and others. Other changes: The code now builds and passes all tests on the AMD64 (running Red Hat Enterprise Linux 3). It also now builds with gcc 4.0 (on FC4). See the OPeNDAP libdap 3.5.2 Release milestone for more information about specific problems that have been fixed.


Linux Tux Logo Linux (i386)
Fedora Core 4, RPMs (gcc 4.0)
Fedora Core 3, RPMs (gcc 3.4)
Red Hat Enterprise Linux 3, RPMs (gcc 3.2.3)
Linux Tux Logo Linux (i386)
Red Hat Enterprise Linux 3, RPMs (gcc 3.2.3)

Source code

Version 3.5.2
tar.gz (1.7 MB). Required: You may need libcurl and/or libxml2. The libdap 3.5.2 software requires libcurl 7.10.6 and libxml2 2.5.7. See our Third-party software page for links to these packages. You may also need the pthreads package.