Back to top

DAP++ SDK 3.5.0 beta (5 May 2005)

Submitted by jimg on Thu, 05/05/2005 - 20:31

This version of libdap++ includes support for the AIS, a new factory-based class instantiation mechanism, the first of the DAP3 features (XML encoding for data previously held in the DAS and DDS) and a streamlined build process. However, the version 3.4.x clients and servers are not compatible with this version of the library. If you want to build those, get libdap 3.4.8. See the README, INSTALL and NEWS files included with the source for more information. This version of the library has been built on Linux (Fedora core 2,3 and RedHat Enterprise v.3) and Mac OS/X 10.3.


Currently this is only a source release.

Source code

Version 3.5.0 beta
tar.gz (1.4 MB). Required: You may need libcurl and/or libxml2. The libdap 3.5.0 software requires libcurl 7.12.0 and libxml2 2.5.7. See our Third-party software page for links to these packages.