Back to top

DAP++ SDK 3.7.8 (26 June 2007)

Submitted by jimg on Tue, 06/26/2007 - 14:24

Version 3.7.8 is mostly a bug-fix release, however, this version also includes support for pkg-config. The NEWS file contained in the source release, along with the matching ChangeLog file, detail the fixes. There are no API changes in this release. Briefly, the fixes include:

  • Memory error with the Regex class on 64-bit machines;
  • Memory error when reading HTTP headers from an older server;


Linux Tux Logo Linux (x86_64)
Fedora Core 6, RPMs (gcc 4.1)

Required packages

The libdap 3.7.8 software requires libcurl 7.10.6, libxml2 2.5.7 and a modern pthreads library. To build from a fresh SVN checkout, you'll need automake 1.9.6, autoconf 2.59 and libtool 1.5.18.

Mac OS/X Mac OS/X 10.4 or greater
You will need to install libxml2; libcurl and pthreads are already present. See the third-party software page or go directly to the libxml2 page.
Linux Tux Logo Linux (x86_64/i386)
Modern versions of Linux come with the needed libraries.
Sun SPARC/SolarisSGI Icon SPARC/Solaris, SGI/IRIX
For these and other Unix distributions you will need to get libcurl, libxml and maybe pthreads. See the third-party software page.

Source code

Version 3.7.8
tar.gz. Required: libcurl, libxml2 and pthreads. See above.

Contributed builds

Version 3.7.8
Contributed: Sharing your binary builds for those operating systems not available here.