Back to top

DAP++ SDK 3.7.7 (3 May 2007)

Submitted by jimg on Thu, 05/03/2007 - 14:17

Version 3.7.7 is a bug-fix release. The NEWS file contained in the source release, along with the matching ChangeLog file, detail the fixes. There are no API changes in this release. Briefly, the fixes include:

  • Build issues with the libraries libdapclient and libdapserver;
  • Fixed a handful of platform-specific build issues;
  • There are some minor performance improvements to the constraint evaluator;
  • Repaired some problems with the server-side functions.


Linux Tux Logo Linux (x86_64)
Fedora Core 6, RPMs (gcc 4.1)
Mac OS/X Mac OS/X
Intel DMG

Required packages

The libdap 3.7.7 software requires libcurl 7.10.6, libxml2 2.5.7 and a modern pthreads library. To build from a fresh SVN checkout, you'll need automake 1.9.6, autoconf 2.59 and libtool 1.5.18.

Mac OS/X Mac OS/X 10.4 or greater
You will need to install libxml2; libcurl and pthreads are already present. See the third-party software page or go directly to the libxml2 page.
Linux Tux Logo Linux (x86_64/i386)
Modern versions of Linux come with the needed libraries.
Sun SPARC/SolarisSGI Icon SPARC/Solaris, SGI/IRIX
For these and other Unix distributions you will need to get libcurl, libxml and maybe pthreads. See the third-party software page.

Source code

Version 3.7.7
tar.gz . Required: libcurl, libxml2 and pthreads. See above.

Contributed builds

Version 3.7.7
Contributed: Sharing your binary builds for those operating systems not available here.